原环境:

  • Flarum
    0.1.0-beta.15
  • PHP
    7.4.15

升级到:

  • Flarum
    0.1.0-beta.16
  • PHP
    8.0.3

Flarum终于推出了第一个rc版本,但是这个版本并不完美,例如无法中文输入(Markdown插件问题),插件fof/upload不适配(附件上传,很重要),还有很多插件未适配

计划观望一个月左右或者等待Flarum 1.0正式版发布

更新1:fof/upload已适配beta16,但依然有待观望

更新2:第二次试图更新

首先看看哪些插件有问题:

[root@RainYun-121013 forum.monika.love]# composer why-not flarum/core v0.1.0-beta.16
clarkwinkelmann/flarum-ext-author-change           0.2.2             requires          flarum/core (>=0.1.0-beta.15 <0.1.0-beta.16)            
clarkwinkelmann/flarum-ext-manual-discussion-slug  0.2.0             requires          flarum/core (>=0.1.0-beta.15 <0.1.0-beta.16)            
clarkwinkelmann/flarum-ext-scratchpad              1.3.0             requires          flarum/core (>=0.1.0-beta.15 <0.1.0-beta.16)            
clarkwinkelmann/flarum-ext-who-read                1.2.2             requires          flarum/core (>=0.1.0-beta.15 <0.1.0-beta.16)            
ffans/clipboardjs                                  v0.1.0-beta.15.2  requires          flarum/core (>=0.1.0-beta.15 <0.1.0-beta.16)            
ffans/lang-simplified-chinese                      v0.1.0-beta.15.2  requires          flarum/core (>=0.1.0-beta.14 <0.1.0-beta.16)            
fof/best-answer                                    0.3.2             requires          flarum/core (>=0.1.0-beta.15 <0.1.0-beta.16)            
fof/html-errors                                    0.5.0             requires          flarum/core (>=0.1.0-beta.15 <0.1.0-beta.16)            
fof/impersonate                                    0.7.0             requires          flarum/core (>=0.1.0-beta.15 <0.1.0-beta.16)            
fof/linguist                                       0.5.0             requires          flarum/core (>=0.1.0-beta.15 <0.1.0-beta.16)            
fof/moderator-notes                                0.4.0             requires          flarum/core (>=0.1.0-beta.15 <0.1.0-beta.16)            
fof/sitemap                                        0.6.0             requires          flarum/core (>=0.1.0-beta.15 <0.1.0-beta.16)            
fof/terms                                          0.6.1             requires          flarum/core (>=0.1.0-beta.15 <0.1.0-beta.16)            
fof/upload                                         0.11.3            requires          flarum/core (>=0.1.0-beta.14 <0.1.0-beta.16)            
itnt/flarum-uitab                                  0.3.0             requires          flarum/core (>=0.1.0-beta.15 <0.1.0-beta.16)            
jordanjay29/flarum-ext-summaries                   0.3.2             requires          flarum/core (>=0.1.0-beta.14 <0.1.0-beta.16)            
maicol07/flarum-ext-sso                            1.8               requires          flarum/core (>=0.1.0-beta.15 <0.1.0-beta.16)            
sycho/flarum-action-log                            v0.1.3            requires          flarum/core (>=0.1.0-beta.15 <0.1.0-beta.16)            
sycho/flarum-advanced-extension-categories         v0.1.0            requires          flarum/core (>=0.1.0-beta.15 <0.1.0-beta.16)            
tedem/flarum-ext-scroll-progress                   v0.1.0            requires          flarum/core (>=0.1.0-beta.15 <0.1.0-beta.16)            
flarum/core                                        v0.1.0-beta.16    requires          dflydev/fig-cookies (^3.0.0)                            
flarum/flarum                                      -                 does not require  dflydev/fig-cookies (but v2.0.3 is installed)           
flarum/core                                        v0.1.0-beta.16    requires          franzl/whoops-middleware (^2.0.0)                       
flarum/flarum                                      -                 does not require  franzl/whoops-middleware (but 0.4.1 is installed)       
flarum/core                                        v0.1.0-beta.16    requires          illuminate/bus (^8.0)                                   
flarum/flarum                                      -                 does not require  illuminate/bus (but v6.20.8 is installed)               
flarum/core                                        v0.1.0-beta.16    requires          illuminate/cache (^8.0)                                 
flarum/flarum                                      -                 does not require  illuminate/cache (but v6.20.8 is installed)             
flarum/core                                        v0.1.0-beta.16    requires          illuminate/config (^8.0)                                
flarum/flarum                                      -                 does not require  illuminate/config (but v6.20.8 is installed)            
flarum/core                                        v0.1.0-beta.16    requires          illuminate/container (^8.0)                             
flarum/flarum                                      -                 does not require  illuminate/container (but v6.20.8 is installed)         
flarum/core                                        v0.1.0-beta.16    requires          illuminate/contracts (^8.0)                             
flarum/flarum                                      -                 does not require  illuminate/contracts (but v6.20.8 is installed)         
flarum/core                                        v0.1.0-beta.16    requires          illuminate/database (^8.0)                              
flarum/flarum                                      -                 does not require  illuminate/database (but v6.20.16 is installed)         
flarum/core                                        v0.1.0-beta.16    requires          illuminate/events (^8.0)                                
flarum/flarum                                      -                 does not require  illuminate/events (but v6.20.8 is installed)            
flarum/core                                        v0.1.0-beta.16    requires          illuminate/filesystem (^8.0)                            
flarum/flarum                                      -                 does not require  illuminate/filesystem (but v6.20.8 is installed)        
flarum/core                                        v0.1.0-beta.16    requires          illuminate/hashing (^8.0)                               
flarum/flarum                                      -                 does not require  illuminate/hashing (but v6.20.8 is installed)           
flarum/core                                        v0.1.0-beta.16    requires          illuminate/mail (^8.0)                                  
flarum/flarum                                      -                 does not require  illuminate/mail (but v6.20.8 is installed)              
flarum/core                                        v0.1.0-beta.16    requires          illuminate/queue (^8.0)                                 
flarum/flarum                                      -                 does not require  illuminate/queue (but v6.20.8 is installed)             
flarum/core                                        v0.1.0-beta.16    requires          illuminate/session (^8.0)                               
flarum/flarum                                      -                 does not require  illuminate/session (but v6.20.8 is installed)           
flarum/core                                        v0.1.0-beta.16    requires          illuminate/support (^8.0)                               
flarum/flarum                                      -                 does not require  illuminate/support (but v6.20.8 is installed)           
flarum/core                                        v0.1.0-beta.16    requires          illuminate/validation (^8.0)                            
flarum/flarum                                      -                 does not require  illuminate/validation (but v6.20.8 is installed)        
flarum/core                                        v0.1.0-beta.16    requires          illuminate/view (^8.0)                                  
flarum/flarum                                      -                 does not require  illuminate/view (but v6.20.8 is installed)              
flarum/core                                        v0.1.0-beta.16    requires          laminas/laminas-diactoros (^2.4.1)                      
flarum/flarum                                      -                 does not require  laminas/laminas-diactoros (but 1.8.7p2 is installed)    
flarum/core                                        v0.1.0-beta.16    requires          middlewares/base-path (^2.0.1)                          
flarum/flarum                                      -                 does not require  middlewares/base-path (but v1.1.0 is installed)         
flarum/core                                        v0.1.0-beta.16    requires          middlewares/base-path-router (^2.0.1)                   
flarum/flarum                                      -                 does not require  middlewares/base-path-router (but v0.2.1 is installed)  
flarum/core                                        v0.1.0-beta.16    requires          middlewares/request-handler (^2.0.1)                    
flarum/flarum                                      -                 does not require  middlewares/request-handler (but v1.4.0 is installed)   
flarum/core                                        v0.1.0-beta.16    requires          symfony/config (^5.2.2)                                 
flarum/flarum                                      -                 does not require  symfony/config (but v4.4.18 is installed)               
flarum/core                                        v0.1.0-beta.16    requires          symfony/console (^5.2.2)                                
flarum/flarum                                      -                 does not require  symfony/console (but v4.4.18 is installed)              
flarum/core                                        v0.1.0-beta.16    requires          symfony/event-dispatcher (^5.2.2)                       
flarum/flarum                                      -                 does not require  symfony/event-dispatcher (but v4.4.18 is installed)     
flarum/core                                        v0.1.0-beta.16    requires          symfony/translation (^5.1.5)                            
flarum/flarum                                      -                 does not require  symfony/translation (but v4.4.18 is installed)          
flarum/core                                        v0.1.0-beta.16    requires          symfony/yaml (^5.2.2)                                   
flarum/flarum                                      -                 does not require  symfony/yaml (but v4.4.18 is installed)                 

我们先卸载掉那些不兼容的扩展

composer remove clarkwinkelmann/flarum-ext-author-change
composer remove clarkwinkelmann/flarum-ext-manual-discussion-slug
composer remove clarkwinkelmann/flarum-ext-scratchpad
composer remove clarkwinkelmann/flarum-ext-who-read
composer remove ffans/clipboardjs
composer remove ffans/lang-simplified-chinese
composer remove fof/best-answer
composer remove fof/html-errors
composer remove fof/impersonate
composer remove fof/linguist
composer remove fof/moderator-notes
composer remove fof/sitemap
composer remove fof/terms
composer remove fof/upload
composer remove itnt/flarum-uitab
composer remove jordanjay29/flarum-ext-summaries
composer remove maicol07/flarum-ext-sso
composer remove sycho/flarum-action-log
composer remove sycho/flarum-advanced-extension-categories
composer remove tedem/flarum-ext-scroll-progress

先备份网站

升级

composer update --prefer-dist --no-plugins --no-dev -a --with-all-dependencies
php flarum migrate
php flarum cache:clear

原来是那两个插件删库跑路了

淦,卸掉fof/pages试试

好耶!!

wc

终于

升级到php8

fileinfo扩展

升级基本完成,等待后续优化